about summary refs log tree commit diff stats
path: root/modules/home/conf/nvim/plgs/lsp/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/home/conf/nvim/plgs/lsp/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.tar.gz
nixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/home/conf/nvim/plgs/lsp/default.nix')
-rw-r--r--modules/home/conf/nvim/plgs/lsp/default.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/modules/home/conf/nvim/plgs/lsp/default.nix b/modules/home/conf/nvim/plgs/lsp/default.nix
deleted file mode 100644
index b7c1e174..00000000
--- a/modules/home/conf/nvim/plgs/lsp/default.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{...}: {
-  imports = [
-    ./keymaps
-    ./servers
-  ];
-  programs.nixvim.plugins.lsp = {
-    enable = true;
-    onAttach =
-      ""
-      #     + ''
-      #        function(client, bufnr)
-      #            -- Enable completion triggered by <c-x><c-o>
-      #            -- vim.api.nvim_buf_set_option(bufnr, 'omnifunc', 'v:lua.vim.lsp.omnifunc')
-      #        end
-      #      ''
-      ;
-    preConfig = ''
-      vim.diagnostic.config({
-          underline = true,
-          -- virtual_text = true,
-          virtual_text = {
-              source = "always", -- Or "if_many"
-          },
-          update_in_insert = true,
-          severity_sort = true,
-      }, nil);
-    '';
-  };
-}