about summary refs log tree commit diff stats
path: root/modules/home/conf/beets/plugins/play/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-11 13:25:34 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-11 13:25:34 +0200
commit90358ae73d237ced75e0e99dba456d2b1461f74d (patch)
treea2e13126e73c5b376600b097e7b6b6e6089ed81f /modules/home/conf/beets/plugins/play/default.nix
parentfix(home/beets): Improve path sorting and awareness of Live recordings (diff)
downloadnixos-config-90358ae73d237ced75e0e99dba456d2b1461f74d.tar.gz
nixos-config-90358ae73d237ced75e0e99dba456d2b1461f74d.zip
refactor(home/beets): Move the plugins out into separate directories
Diffstat (limited to 'modules/home/conf/beets/plugins/play/default.nix')
-rw-r--r--modules/home/conf/beets/plugins/play/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/home/conf/beets/plugins/play/default.nix b/modules/home/conf/beets/plugins/play/default.nix
new file mode 100644
index 00000000..f5bc3c9b
--- /dev/null
+++ b/modules/home/conf/beets/plugins/play/default.nix
@@ -0,0 +1,14 @@
+{
+  lib,
+  pkgs,
+  config,
+  ...
+}: {
+  programs.beets.settings.play = {
+    command = "${lib.getExe pkgs.mpc-cli} $args add";
+    relative_to = config.services.mpd.musicDirectory;
+
+    # Run the command with the returned paths as arguments
+    raw = true;
+  };
+}