about summary refs log tree commit diff stats
path: root/modules/home/conf/beets/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/home/conf/beets/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.tar.gz
nixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/home/conf/beets/default.nix')
-rw-r--r--modules/home/conf/beets/default.nix103
1 files changed, 0 insertions, 103 deletions
diff --git a/modules/home/conf/beets/default.nix b/modules/home/conf/beets/default.nix
deleted file mode 100644
index 8d6277b7..00000000
--- a/modules/home/conf/beets/default.nix
+++ /dev/null
@@ -1,103 +0,0 @@
-{
-  pkgs,
-  lib,
-  config,
-  ...
-}: let
-  plugins = import ./plugins.nix {};
-in {
-  imports = [
-    ./plugins
-  ];
-
-  programs.beets = {
-    enable = true;
-    package = pkgs.beets.override {
-      pluginOverrides = {
-        xtractor = {
-          enable = true;
-          propagatedBuildInputs = [pkgs.beetsExtraPlugins.xtractor];
-        };
-      };
-    };
-
-    settings = {
-      library = "${config.xdg.dataHome}/beets/library.db";
-      art_filename = "cover";
-      directory = "${config.xdg.userDirs.music}/beets";
-      ui = {
-        color = true;
-      };
-
-      include = [
-        "./replace_override.yaml"
-      ];
-
-      import = {
-        # move, instead of copying or linking the files
-        copy = false;
-        move = true;
-        link = false;
-
-        # Show more detail, when beet needs to ask for something
-        detail = true;
-
-        incremental = false;
-
-        # Write the metadata to the files
-        write = true;
-        log = "${config.xdg.dataHome}/beets/beetslog.txt";
-      };
-
-      paths = let
-        j = lib.strings.concatStringsSep "/";
-      in {
-        default = j ["[Default]" "$genre" "$first_artist" "$album ($albumtype)" "$track $title"];
-        "albumtype:live" = j ["[Live]" "$genre" "$first_artist" "$album ($albumtype)" "$track $title"];
-
-        "albumtype:album" = j ["Music" "$genre" "$first_artist" "$album ($albumtype)" "$track $title"];
-        "albumtype::(Single|EP)" = j ["Music" "$genre" "$first_artist_singleton" "$album ($albumtype)" "$track $title"];
-        "albumtype:compilation" = j ["Complilations" "$genre" "Various Artists" "$album ($albumtype)" "$track $title"];
-        "albumtype:soundtrack" = j ["Soundtracks" "$genre" "$first_artist" "$album" "$track $title"];
-      };
-
-      inherit plugins;
-
-      # Plugin config
-      # scrub = {
-      #   auto = true;
-      # };
-
-      musicbrainz = {
-        # Search for deezer id's and use them in the autotagger
-        # external_ids = {
-        #   deezer = true;
-        # };
-      };
-
-      # Log-on config
-      # TODO: Add this, to upload the generated fingerprints (to help improve their
-      # database) <2024-08-07>
-      # acoustid = {
-      #   apikey = "TODO";
-      # };
-    };
-
-    mpdIntegration = {
-      enableStats = true;
-      enableUpdate = true;
-      host = config.home.sessionVariables.MPD_HOST;
-    };
-  };
-
-  xdg.configFile."beets/replace_override.yaml".source = ./replace_override.yaml;
-
-  # Use the json formatter instead of the YAML one, as the YAML formatter mangles the
-  # longer python inline strings.
-  # YAML is a superset of JSON.
-  xdg.configFile."beets/config.yaml".source =
-    lib.mkForce
-    ((pkgs.formats.json {}).generate
-      "beets-config"
-      config.programs.beets.settings);
-}