about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/ytcc/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/home.legacy/conf/ytcc/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.tar.gz
nixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/home.legacy/conf/ytcc/default.nix')
-rw-r--r--modules/home.legacy/conf/ytcc/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/ytcc/default.nix b/modules/home.legacy/conf/ytcc/default.nix
new file mode 100644
index 00000000..87300ec1
--- /dev/null
+++ b/modules/home.legacy/conf/ytcc/default.nix
@@ -0,0 +1,11 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  xdg.configFile."ytcc/ytcc.conf".source = pkgs.substituteAll {
+    src = ./ytcc.conf;
+    download_dir = "${config.xdg.userDirs.download}/ytcc";
+    xdg_data_home = config.xdg.dataHome;
+  };
+}