about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/python/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-21 22:42:14 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-21 22:42:14 +0200
commit4ce5e1a51aab22540a21d7fe38fadc7c8bcb3893 (patch)
tree78fbdf0354bf81a05922d57d81d0479ea5563ff8 /modules/home.legacy/conf/python/default.nix
parentfeat(modules/zsh): Nearly completely rewrite (diff)
downloadnixos-config-4ce5e1a51aab22540a21d7fe38fadc7c8bcb3893.tar.gz
nixos-config-4ce5e1a51aab22540a21d7fe38fadc7c8bcb3893.zip
fix(modules/*): Set all xdg-basedir env vars independently of active shell
There is now reason, why these variables should only be used when `zsh`
is running.
Diffstat (limited to 'modules/home.legacy/conf/python/default.nix')
-rw-r--r--modules/home.legacy/conf/python/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/home.legacy/conf/python/default.nix b/modules/home.legacy/conf/python/default.nix
index 826d466d..09f5c5ce 100644
--- a/modules/home.legacy/conf/python/default.nix
+++ b/modules/home.legacy/conf/python/default.nix
@@ -1,6 +1,6 @@
 {config, ...}: {
   xdg.configFile."python/pythonrc".source = ./pythonrc.py;
-  programs.zsh.sessionVariables = {
+  home.sessionVariables = {
     "PYTHONSTARTUP" = "${config.xdg.configHome}/python/pythonrc";
   };
 }