about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/treesitter/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-11-09 12:35:44 +0100
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-11-09 12:54:51 +0100
commit2122a01f99c6da466b8f0f55c965c11a9043d117 (patch)
tree6c1697afc30a5bb72635bda7db9b5610386a5b71 /modules/home.legacy/conf/nvim/plgs/treesitter/default.nix
parentfix(pkgs/stamp): Fallback to `dot-license` (diff)
downloadnixos-config-2122a01f99c6da466b8f0f55c965c11a9043d117.tar.gz
nixos-config-2122a01f99c6da466b8f0f55c965c11a9043d117.zip
refactor(modules/legacy/conf/nvim): Move to `by-name`
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/treesitter/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/treesitter/default.nix59
1 files changed, 0 insertions, 59 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/treesitter/default.nix b/modules/home.legacy/conf/nvim/plgs/treesitter/default.nix
deleted file mode 100644
index b4b20388..00000000
--- a/modules/home.legacy/conf/nvim/plgs/treesitter/default.nix
+++ /dev/null
@@ -1,59 +0,0 @@
-{
-  config,
-  pkgs,
-  lib,
-  ...
-}: {
-  programs.nixvim = {
-    plugins.treesitter = {
-      enable = true;
-
-      # NOTE: These are required to build grammars, but I already use the nix grammars <2024-07-13>
-      gccPackage = null;
-      nodejsPackage = null;
-      treesitterPackage = null;
-
-      # inject nixvim specific highlighting (eg in extraConfigLua).
-      nixvimInjections = true;
-
-      nixGrammars = true;
-      grammarPackages =
-        config.programs.nixvim.plugins.treesitter.package.passthru.allGrammars
-        ++ [pkgs.tree-sitter-yts];
-
-      settings = {
-        auto_install = false;
-        ensureInstalled = "all";
-        indent.enable = true;
-        disabledLanguages = [];
-
-        highlight = {
-          enable = true;
-          disable = [];
-
-          #  Setting this to true will run `:h syntax` and tree-sitter at the same time.
-          #  Set this to `true` if you depend on 'syntax' being enabled (like for indentation).
-          #  Using this option may slow down your editor; and you may see some duplicate highlights.
-          #  Instead of true it can also be a list of languages
-          additionalVimRegexHighlighting = ["latex"];
-        };
-
-        incrementalSelection = {
-          enable = true;
-          keymaps = {
-            # TODO: include these in the which-key description
-            initSelection = "gnn"; #  set to `false` to disable one of the mappings
-            nodeIncremental = "grn";
-            scopeIncremental = "grc";
-            nodeDecremental = "grm";
-          };
-        };
-      };
-    };
-    extraFiles = {
-      "queries/yts/highlights.scm".text = ''
-        ${lib.strings.fileContents "${pkgs.tree-sitter-yts}/queries/highlights.scm"}
-      '';
-    };
-  };
-}