about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-11-09 12:35:44 +0100
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-11-09 12:54:51 +0100
commit2122a01f99c6da466b8f0f55c965c11a9043d117 (patch)
tree6c1697afc30a5bb72635bda7db9b5610386a5b71 /modules/home.legacy/conf/nvim/default.nix
parentfix(pkgs/stamp): Fallback to `dot-license` (diff)
downloadnixos-config-2122a01f99c6da466b8f0f55c965c11a9043d117.tar.gz
nixos-config-2122a01f99c6da466b8f0f55c965c11a9043d117.zip
refactor(modules/legacy/conf/nvim): Move to `by-name`
Diffstat (limited to 'modules/home.legacy/conf/nvim/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/default.nix55
1 files changed, 0 insertions, 55 deletions
diff --git a/modules/home.legacy/conf/nvim/default.nix b/modules/home.legacy/conf/nvim/default.nix
deleted file mode 100644
index 2da80c22..00000000
--- a/modules/home.legacy/conf/nvim/default.nix
+++ /dev/null
@@ -1,55 +0,0 @@
-{pkgs, ...}: {
-  imports = [
-    ./autocmds
-    ./clipboard
-    ./files
-    ./mappings
-    ./options
-    ./plgs
-  ];
-  home.sessionVariables = {
-    EDITOR = "nvim";
-    VISUAL = "nvim";
-    CODEEDITOR = "nvim";
-  };
-  programs.nixvim = {
-    enable = true;
-
-    # source: https://www.patorjk.com/software/taag/#p=display&f=ANSI%20Shadow&t=Neovim
-    extraConfigLuaPre =
-      /*
-       FIXME: Update the merge function to support that: <2023-08-29>
-
-      lib.mkBefore
-      */
-      ''
-        ---------------------------------------------------------------------------
-        --
-        --     ███╗   ██╗███████╗ ██████╗ ██╗   ██╗██╗███╗   ███╗
-        --     ████╗  ██║██╔════╝██╔═══██╗██║   ██║██║████╗ ████║
-        --     ██╔██╗ ██║█████╗  ██║   ██║██║   ██║██║██╔████╔██║
-        --     ██║╚██╗██║██╔══╝  ██║   ██║╚██╗ ██╔╝██║██║╚██╔╝██║
-        --     ██║ ╚████║███████╗╚██████╔╝ ╚████╔╝ ██║██║ ╚═╝ ██║
-        --     ╚═╝  ╚═══╝╚══════╝ ╚═════╝   ╚═══╝  ╚═╝╚═╝     ╚═╝
-        --
-        ---------------------------------------------------------------------------
-      '';
-
-    extraPackages = with pkgs; [
-      /*
-      These are mostly linters and formatters used for different file types.
-      Including them here is fine, as they are not necessarily sync able to different people.
-      */
-      # nix
-      alejandra
-      statix
-
-      # yaml
-      yamllint
-
-      # shell
-      shellcheck
-      shfmt
-    ];
-  };
-}