about summary refs log tree commit diff stats
path: root/modules/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.tar.gz
nixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/default.nix')
-rw-r--r--modules/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/default.nix b/modules/default.nix
new file mode 100644
index 00000000..a3bc1735
--- /dev/null
+++ b/modules/default.nix
@@ -0,0 +1,10 @@
+# NOTE: This file **must** not depend on `pkgs`. This is because `pkgs` is defined in a
+# module imported by it, and thus would require infinite recursion.  <2024-10-18>
+{...}: let
+  files = import ./by-name-overlay.nix {
+    baseDirectory =
+      ./by-name;
+  };
+in {
+  imports = files;
+}