about summary refs log tree commit diff stats
path: root/modules/by-name/xd/xdg/module.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/by-name/xd/xdg/module.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.tar.gz
nixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/by-name/xd/xdg/module.nix')
-rw-r--r--modules/by-name/xd/xdg/module.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/modules/by-name/xd/xdg/module.nix b/modules/by-name/xd/xdg/module.nix
new file mode 100644
index 00000000..5140a832
--- /dev/null
+++ b/modules/by-name/xd/xdg/module.nix
@@ -0,0 +1,58 @@
+{
+  pkgs,
+  nixpkgs_open_prs,
+  sysLib,
+  system,
+  ...
+}: let
+  pkgs_tfc = nixpkgs_open_prs.nixpkgs-tfc.legacyPackages."${system}";
+in {
+  services.dbus.enable = true;
+  xdg = {
+    portal = {
+      enable = true;
+      termfilechooser = {
+        enable = true;
+        logLevel = "TRACE";
+        package = pkgs_tfc.xdg-desktop-portal-termfilechooser;
+        settings = {
+          filechooser = {
+            default_dir = "/tmp";
+            cmd = "${sysLib.writeShellScript {
+              src = ./scripts/lf_wrapper.sh;
+              name = "lf_wrapper";
+              keepPath = true;
+              dependencies = with pkgs; [
+                lf
+                alacritty
+                bash
+              ];
+            }}/bin/lf_wrapper";
+          };
+        };
+      };
+      wlr = {
+        enable = true;
+      };
+      config = {
+        common = {
+          # NOTE: The next entry is supposedly needed for gtk based apps <2023-08-31>
+          default = ["wlr" "gtk"];
+          "org.freedesktop.impl.portal.FileChooser" = ["termfilechooser"];
+        };
+
+        # TODO: Also activate, when on another wlr-based compositor <2023-11-25>
+        river = {
+          default = ["wlr" "gtk"];
+          "org.freedesktop.impl.portal.FileChooser" = ["termfilechooser"];
+        };
+      };
+      extraPortals = [
+        pkgs.xdg-desktop-portal-gtk
+        pkgs.xdg-desktop-portal-wlr
+        pkgs_tfc.xdg-desktop-portal-termfilechooser
+      ];
+    };
+  };
+  # TODO: mime = {};
+}