about summary refs log tree commit diff stats
path: root/modules/by-name/li/libvirtd/module.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/by-name/li/libvirtd/module.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.tar.gz
nixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/by-name/li/libvirtd/module.nix')
-rw-r--r--modules/by-name/li/libvirtd/module.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/modules/by-name/li/libvirtd/module.nix b/modules/by-name/li/libvirtd/module.nix
new file mode 100644
index 00000000..5c519550
--- /dev/null
+++ b/modules/by-name/li/libvirtd/module.nix
@@ -0,0 +1,27 @@
+{pkgs, ...}: {
+  # virtualisation = {
+  # spiceUSBRedirection.enable = true; # TODO: this allows usb access to any user, which shouldn't be that bad
+  #    cores = 8;
+  #    diskSize = 25000;
+  #    useEFIBoot = true;
+  #    resolution = {
+  #      x = 1920;
+  #      y = 1080;
+  #    };
+  #    memorySize = 8024;
+  #    sharedDirectories = {}; # TODO: add some
+  #   libvirtd = {
+  #     enable = true;
+  #     qemu = {
+  #       package = pkgs.qemu_full;
+  #       ovmf = {
+  #         enable = true;
+  #         packages = [pkgs.OVMFFull.fd];
+  #       };
+  #     };
+  #   };
+  # };
+  # users.users.soispha.extraGroups = [
+  #   "libvirtd" # to run libvirt stuff as this user
+  # ];
+}