about summary refs log tree commit diff stats
path: root/hosts/IDOHVE/hardware/hardware.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-04 11:54:55 +0100
committerene <ene@sils.li>2023-02-04 11:55:56 +0100
commit75b442acb64bac70294681ae6d318a470afeac3c (patch)
treef05216df9e251e826188d4e8bfa6024af14078a4 /hosts/IDOHVE/hardware/hardware.nix
parentFix(packages): Removed already by nixos managed ones (diff)
downloadnixos-config-75b442acb64bac70294681ae6d318a470afeac3c.tar.gz
nixos-config-75b442acb64bac70294681ae6d318a470afeac3c.zip
Feat: Made more configuration host independent
Diffstat (limited to 'hosts/IDOHVE/hardware/hardware.nix')
-rw-r--r--hosts/IDOHVE/hardware/hardware.nix15
1 files changed, 13 insertions, 2 deletions
diff --git a/hosts/IDOHVE/hardware/hardware.nix b/hosts/IDOHVE/hardware/hardware.nix
index 2d21ce8a..c36b7062 100644
--- a/hosts/IDOHVE/hardware/hardware.nix
+++ b/hosts/IDOHVE/hardware/hardware.nix
@@ -9,9 +9,20 @@
     (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
     ./cpu.nix
     ./gpu.nix
-    ./boot.nix
-    ./filesystems.nix
   ];
 
   nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+
+  system.filesystemLayouts = {
+    enable = true;
+    mainDisk = "/dev/disk/by-uuid/<uuid>";
+    efiDisk = "/dev/disk/by-uuid/<uuid>";
+  };
+
+  boot = {
+    kernelModules = ["kvm-amd"];
+
+    # TODO check this:
+    initrd.availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
+  };
 }