about summary refs log tree commit diff stats
path: root/hosts/IDOHVE/gpu.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-01 20:22:29 +0100
committerene <ene@sils.li>2023-02-01 20:28:24 +0100
commita806c6776ea19ec068b7a60fde211310fd41d156 (patch)
treeb34083424e759459473b13b7c2f9f75cf9e8a80e /hosts/IDOHVE/gpu.nix
downloadnixos-config-a806c6776ea19ec068b7a60fde211310fd41d156.tar.gz
nixos-config-a806c6776ea19ec068b7a60fde211310fd41d156.zip
Initial commit
Diffstat (limited to 'hosts/IDOHVE/gpu.nix')
-rw-r--r--hosts/IDOHVE/gpu.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/hosts/IDOHVE/gpu.nix b/hosts/IDOHVE/gpu.nix
new file mode 100644
index 00000000..6796d04b
--- /dev/null
+++ b/hosts/IDOHVE/gpu.nix
@@ -0,0 +1,17 @@
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}: {
+  hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware; # TODO
+
+  hardware.opengl.extraPackages = with pkgs; [
+    rocm-opencl-icd # open-cl
+    amdvlk # or directly through mesa
+    amd-media-driver # libva
+  ];
+
+  # Force radv, TODO is this logical?
+  environment.variables.AMD_VULKAN_ICD = "RADV";
+}