about summary refs log tree commit diff stats
path: root/hosts/Apzu/hardware/hardware.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-05 13:00:04 +0100
committerene <ene@sils.li>2023-02-05 13:00:04 +0100
commit47a69f76ec6241ac7c933dfba49455b3d364a6eb (patch)
tree09215dcf8a01980090c08ed9ad86171d52f800a7 /hosts/Apzu/hardware/hardware.nix
parentFix: This fixes the booting process somehow? (diff)
downloadnixos-config-47a69f76ec6241ac7c933dfba49455b3d364a6eb.tar.gz
nixos-config-47a69f76ec6241ac7c933dfba49455b3d364a6eb.zip
Feat: Switch to Default.nix files
This make the imported path somewhat shorter.
Diffstat (limited to 'hosts/Apzu/hardware/hardware.nix')
-rw-r--r--hosts/Apzu/hardware/hardware.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/hosts/Apzu/hardware/hardware.nix b/hosts/Apzu/hardware/hardware.nix
deleted file mode 100644
index c36b7062..00000000
--- a/hosts/Apzu/hardware/hardware.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  modulesPath,
-  ...
-}: {
-  imports = [
-    (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
-    ./cpu.nix
-    ./gpu.nix
-  ];
-
-  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
-
-  system.filesystemLayouts = {
-    enable = true;
-    mainDisk = "/dev/disk/by-uuid/<uuid>";
-    efiDisk = "/dev/disk/by-uuid/<uuid>";
-  };
-
-  boot = {
-    kernelModules = ["kvm-amd"];
-
-    # TODO check this:
-    initrd.availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
-  };
-}