about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plgs/telescope/extensions/frecency/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-10-08 13:12:44 +0200
committerSoispha <soispha@vhack.eu>2023-10-08 13:12:44 +0200
commit8fbcfc8698f97fc4701d09cb3de3e095d5ddd7c7 (patch)
tree90530153a36e969569115c6e06ea17c473826670 /hm/soispha/conf/nvim/plgs/telescope/extensions/frecency/default.nix
parentchore(version): v1.15.0 (diff)
downloadnixos-config-8fbcfc8698f97fc4701d09cb3de3e095d5ddd7c7.tar.gz
nixos-config-8fbcfc8698f97fc4701d09cb3de3e095d5ddd7c7.zip
fix(hm/conf/nvim): Update to new keymap format
Diffstat (limited to 'hm/soispha/conf/nvim/plgs/telescope/extensions/frecency/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plgs/telescope/extensions/frecency/default.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/hm/soispha/conf/nvim/plgs/telescope/extensions/frecency/default.nix b/hm/soispha/conf/nvim/plgs/telescope/extensions/frecency/default.nix
index 4a4c22be..b236f3c5 100644
--- a/hm/soispha/conf/nvim/plgs/telescope/extensions/frecency/default.nix
+++ b/hm/soispha/conf/nvim/plgs/telescope/extensions/frecency/default.nix
@@ -1,14 +1,14 @@
 {...}: {
   programs.nixvim = {
-    maps = {
-      normal = {
-        "gff" = {
-          action = "function() require('telescope').extensions.frecency.frecency() end";
-          lua = true;
-          desc = "activate the frecency file selection";
-        };
-      };
-    };
+    keymaps = [
+      {
+        key = "gff";
+        mode = "n";
+        action = "function() require('telescope').extensions.frecency.frecency() end";
+        lua = true;
+        options.desc = "activate the frecency file selection";
+      }
+    ];
     plugins.telescope = {
       extensions.frecency = {
         enable = true;