about summary refs log tree commit diff stats
path: root/flake/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-02-20 17:41:24 +0100
committerSoispha <soispha@vhack.eu>2024-02-20 17:41:24 +0100
commit6cd532b3d2ba026dec01443590c1236944119826 (patch)
tree028569a6898e06b9850700ae76b30da55605696b /flake/default.nix
parentbuild(treewide): Update (diff)
downloadnixos-config-6cd532b3d2ba026dec01443590c1236944119826.tar.gz
nixos-config-6cd532b3d2ba026dec01443590c1236944119826.zip
fix(flake): Don't format `CHANGELOG.md`
Diffstat (limited to 'flake/default.nix')
-rw-r--r--flake/default.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/flake/default.nix b/flake/default.nix
index 7f28abb5..bafb40f4 100644
--- a/flake/default.nix
+++ b/flake/default.nix
@@ -133,12 +133,15 @@
         taplo.enable = true;
       };
 
-      settings.formatter = {
-        clang-format = {
-          options = ["--style" "GNU"];
-        };
-        shfmt = {
-          includes = ["*.bash"];
+      settings = {
+        global.excludes = ["CHANGELOG.md"];
+        formatter = {
+          clang-format = {
+            options = ["--style" "GNU"];
+          };
+          shfmt = {
+            includes = ["*.bash"];
+          };
         };
       };
     }