about summary refs log tree commit diff stats
path: root/flake/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-07-15 20:09:17 +0200
committerSoispha <soispha@vhack.eu>2023-07-15 20:09:55 +0200
commit59bc28565f102c0ce17d3cf513cdab058608b0dc (patch)
tree66623f11d41a435790612a4880d5ab05dc2e9716 /flake/default.nix
parentFix(system/disks/hibernate): Try to activate it (diff)
downloadnixos-config-59bc28565f102c0ce17d3cf513cdab058608b0dc.tar.gz
nixos-config-59bc28565f102c0ce17d3cf513cdab058608b0dc.zip
Feat(system/boot): Enable lanzaboote (and with it secure boot)
Diffstat (limited to 'flake/default.nix')
-rw-r--r--flake/default.nix29
1 files changed, 23 insertions, 6 deletions
diff --git a/flake/default.nix b/flake/default.nix
index e78b957e..45bec03b 100644
--- a/flake/default.nix
+++ b/flake/default.nix
@@ -13,6 +13,7 @@
   ragenix,
   serverphone,
   disko,
+  lanzaboote,
   # external dependencies
   neovim_config,
   user_js,
@@ -73,8 +74,9 @@
 
     disko.nixosModules.default
 
-    home-manager.nixosModules.home-manager
+    lanzaboote.nixosModules.lanzaboote
 
+    home-manager.nixosModules.home-manager
     homeManagerConfig
 
     impermanence.nixosModules.impermanence
@@ -130,17 +132,32 @@ in {
   devShells."${system}" = {
     default = pkgs.mkShell {
       packages = with pkgs; [
-        alejandra
+        # secure boot
+        sbctl
+        # spells
+        ltex-ls
+
+        # other
         cocogitto
-        generate_firefox_extensions.packages."${system}".default # needed for the firefox extension update script
         git-bug
-        ltex-ls
+
+        # nix
+        alejandra
         nil
+        statix
+
+        # yaml
+        yamllint
+
+        # secrets
         ragenix.packages."${system}".default
+
+        # shell
         shellcheck
         shfmt
-        statix
-        yamllint
+
+        # update
+        generate_firefox_extensions.packages."${system}".default # needed for the firefox extension update script
       ];
     };
   };