about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-04-10 10:55:12 +0200
committerSoispha <soispha@vhack.eu>2023-05-09 19:30:00 +0200
commitd771ea7b307cf1f65afbb894d0df34443ddcad0c (patch)
treecc02e0d22a7f6a3d3043b9b419351a51cfa895d4 /flake.nix
parentFeat(hm/pkgs): Add anki (diff)
downloadnixos-config-d771ea7b307cf1f65afbb894d0df34443ddcad0c.tar.gz
nixos-config-d771ea7b307cf1f65afbb894d0df34443ddcad0c.zip
Feat(flake): Activate content-addressed derivations
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index e7906724..35fc36b2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -88,11 +88,14 @@
     sysLib = import ./lib {inherit pkgs shell-library;};
     system = "x86_64-linux";
     pkgs = import inputs.nixpkgs {
-      config.allowUnfreePredicate = pkg:
-        builtins.elem (inputs.nixpkgs.lib.getName pkg) [
-          "steam"
-          "steam-original"
-        ];
+      config = {
+        contentAddressedByDefault = true;
+        config.allowUnfreePredicate = pkg:
+          builtins.elem (inputs.nixpkgs.lib.getName pkg) [
+            "steam"
+            "steam-original"
+          ];
+      };
       inherit system;
     };
   in {