about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-04-10 12:32:27 +0200
committerSoispha <soispha@vhack.eu>2023-05-09 19:30:06 +0200
commitc28efb453df4d7f125dc69a6c89bef9c66f69500 (patch)
treed82b98f1653ed26ea7422ff65b6f0b40ca1cca94 /flake.nix
parentFix(flake): Only activate ca-derivations after feature activate (diff)
downloadnixos-config-c28efb453df4d7f125dc69a6c89bef9c66f69500.tar.gz
nixos-config-c28efb453df4d7f125dc69a6c89bef9c66f69500.zip
Fix(treewide): Make system compile again
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 3 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index b8d9890e..466b7d01 100644
--- a/flake.nix
+++ b/flake.nix
@@ -72,6 +72,7 @@
     # modules
     impermanence,
     agenix,
+    ragenix,
     # external dependencies
     neovim_config,
     user_js,
@@ -87,22 +88,13 @@
   }: let
     sysLib = import ./lib {inherit pkgs shell-library;};
     system = "x86_64-linux";
-    pkgs = import nixpkgs {
-      config = {
-#contentAddressedByDefault = true;
-        config.allowUnfreePredicate = pkg:
-          builtins.elem (nixpkgs.lib.getName pkg) [
-            "steam"
-            "steam-original"
-          ];
-      };
-      inherit system;
-    };
+    pkgs = nixpkgs.legacyPackages.${system};
   in {
     nixosConfigurations = import ./flake/nixosConfigurations {
       inherit
         system
         pkgs
+        nixpkgs
         sysLib
         home-manager
         agenix