about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-03-23 15:33:12 +0100
committerSoispha <soispha@vhack.eu>2024-03-23 15:33:12 +0100
commitbc388c1d27444b75aa8825f28f2caabfec26861d (patch)
treef55a83064e4b8d7eb57bc8d1f2239bc793934401 /flake.nix
parentfix(flake): Use new vendored `generate_firefox_extensions` binary (diff)
downloadnixos-config-bc388c1d27444b75aa8825f28f2caabfec26861d.tar.gz
nixos-config-bc388c1d27444b75aa8825f28f2caabfec26861d.zip
fix(flake): Import my modules stuck in nixpkgs prs directly
That makes it possible to use plain `nixpkgs-unstable` for the whole
system, whilst still using my unmerged modules and packages.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 4226578b..648b164a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,8 +3,8 @@
 
   inputs = {
     # base
-    # nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
-    nixpkgs.url = "github:soispha/nixpkgs/tfc-unstable";
+    nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+    nixpkgs-tfc.url = "github:soispha/nixpkgs/add-termfilechooser";
     nixpkgs-stable.url = "github:NixOS/nixpkgs/nixos-23.05";
 
     # inputs for following
@@ -237,6 +237,7 @@
     # core
     self,
     nixpkgs,
+    nixpkgs-tfc,
     # modules
     home-manager,
     nixos-generators,
@@ -268,8 +269,10 @@
       config = self.nixosConfigurations.tiamat.config.home-manager.users.soispha;
       overlays = [];
     });
+
     # FIXME: this `nixpkgs` misses the configs applied to the other one
     nixpkgs_as_input = nixpkgs;
+    nixpkgs_tfc = nixpkgs-tfc;
     outputs = import ./flake {
       inherit
         # core
@@ -278,6 +281,7 @@
         system
         sysLib
         nixpkgs_as_input
+        nixpkgs_tfc
         # modules
         
         home-manager