about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-05-02 19:01:20 +0200
committerSoispha <soispha@vhack.eu>2023-05-09 19:33:02 +0200
commitac03a06feac83b721ab919241c1c5753a8ce3196 (patch)
tree57e68d7b02442a53e51535adb41bec442a62d876 /flake.nix
parentFeat(hm/conf/zsh): Enable command line editing (diff)
downloadnixos-config-ac03a06feac83b721ab919241c1c5753a8ce3196.tar.gz
nixos-config-ac03a06feac83b721ab919241c1c5753a8ce3196.zip
Feat(hm/pkgs): Add flake_update
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 0923bd25..7715d24c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -139,6 +139,15 @@
         flake-utils.follows = "flake-utils";
       };
     };
+    flake_update = {
+      url = "git+https://codeberg.org/soispha/flake_update.git";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        systems.follows = "systems";
+        flake-utils.follows = "flake-utils";
+        shell_library.follows = "shell_library";
+      };
+    };
 
     # external resources
     user_js = {
@@ -174,6 +183,7 @@
     yambar_memory,
     yambar_cpu,
     grades,
+    flake_update,
     ...
   }: let
     sysLib = shell_library.lib.${system};
@@ -212,6 +222,7 @@
         yambar_memory
         yambar_cpu
         grades
+        flake_update
         ;
     };
   in