about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-06-06 12:55:48 +0200
committerSoispha <soispha@vhack.eu>2023-06-06 12:55:48 +0200
commita2a5ee2f180caaf84c25df79ebdedd06f28dde90 (patch)
tree0a6b5a68337f6ad8ccef483ebf8ed6fb3e00892a /flake.nix
parentFix(hm/conf/swaylock): Switch to different wp (diff)
downloadnixos-config-a2a5ee2f180caaf84c25df79ebdedd06f28dde90.tar.gz
nixos-config-a2a5ee2f180caaf84c25df79ebdedd06f28dde90.zip
Feat(system/services/serverphone): Add
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 35e47226..7f6f1f3c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -70,6 +70,17 @@
       url = "github:nix-community/nixos-generators";
       inputs.nixpkgs.follows = "nixpkgs";
     };
+    serverphone = {
+      url = "git+https://codeberg.org/vhack.eu/serverphone.git";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        systems.follows = "systems";
+        flake-compat.follows = "flake-compat";
+        flake-utils.follows = "flake-utils";
+        rust-overlay.follows = "rust-overlay";
+        crane.follows = "crane";
+      };
+    };
 
     # my configs
     neovim_config = {
@@ -195,6 +206,7 @@
     impermanence,
     agenix,
     ragenix,
+    serverphone,
     # external dependencies
     neovim_config,
     user_js,
@@ -233,6 +245,7 @@
         impermanence
         agenix
         ragenix
+        serverphone
         # external dependencies
         
         neovim_config