about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-03-24 16:33:41 +0100
committerSoispha <soispha@vhack.eu>2024-03-24 16:37:14 +0100
commit9ce56f0d31299c27f6f22234b7904acd87412643 (patch)
tree27f6d12d8ea672fb6222bd4b7e8b83d1bf03754a /flake.nix
parentrefactor(flake): Use an attrs for including open prs (diff)
downloadnixos-config-9ce56f0d31299c27f6f22234b7904acd87412643.tar.gz
nixos-config-9ce56f0d31299c27f6f22234b7904acd87412643.zip
fix(hm/conf/gpg): Add my nixpkgs fork to ensure a working gpg-agent
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index f56b5e21..1a0e295c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -7,6 +7,7 @@
     nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
     # open nixpkgs prs
     nixpkgs-tfc.url = "github:soispha/nixpkgs/add-termfilechooser";
+    nixpkgs-onlykey.url = "github:soispha/nixpkgs/fix-onlykey-agent";
 
     # inputs for following
     systems = {
@@ -239,6 +240,7 @@
     self,
     nixpkgs,
     nixpkgs-tfc,
+    nixpkgs-onlykey,
     # modules
     home-manager,
     nixos-generators,
@@ -276,6 +278,7 @@
     nixpkgs_open_prs = {
       inherit
         nixpkgs-tfc
+        nixpkgs-onlykey
         ;
     };
     outputs = import ./flake {
@@ -288,7 +291,7 @@
         nixpkgs_as_input
         nixpkgs_open_prs
         # modules
-
+        
         home-manager
         nixVim
         nixos-generators
@@ -300,12 +303,12 @@
         lanzaboote
         nix-index-database
         # external dependencies
-
+        
         treefmt-nix
         user_js
         templates
         # my binaries
-
+        
         shell_library
         river_init_lesser
         yambar_memory