about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 18:24:03 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 18:24:03 +0200
commit96bf5aa00bbf2499c47c887b2217570657d0011d (patch)
tree9f337470fc0d59de834c407e14c1eadf0c059d78 /flake.nix
parentrefactor(modules/home/pkgs): Readd whilst using the new `pkgs` (diff)
downloadnixos-config-96bf5aa00bbf2499c47c887b2217570657d0011d.tar.gz
nixos-config-96bf5aa00bbf2499c47c887b2217570657d0011d.zip
refactor(nixpkgs): Configure nixpkgs via the module system
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 9 insertions, 10 deletions
diff --git a/flake.nix b/flake.nix
index 03da41a6..572b4e07 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,5 +1,5 @@
 {
-  description = "NixOS system config";
+  description = "A NixOS System Configuration";
 
   inputs = {
     # base
@@ -265,17 +265,14 @@
     yambar_cpu,
     ...
   }: let
-    sysLib = shell_library.lib.${system};
     system = "x86_64-linux";
-    pkgs = import nixpkgs (import ./sys/nixpkgs {
-      inherit (nixpkgs) lib;
-      inherit system sysLib;
-      # FIXME: Don't unconditionally use tiamat here <2024-02-24>
-      config = self.nixosConfigurations.tiamat.config.home-manager.users.soispha;
-      overlays = [];
-    });
+    sysLib = shell_library.lib.${system};
+
+    pkgs = nixpkgs.legacyPackages.${system};
+    myPkgs = import ./pkgs {
+      inherit sysLib pkgs;
+    };
 
-    # FIXME: this `nixpkgs` misses the configs applied to the other one
     nixpkgs_as_input = nixpkgs;
     nixpkgs_open_prs = {
       inherit
@@ -283,11 +280,13 @@
         nixpkgs-onlykey
         ;
     };
+
     outputs = import ./flake {
       inherit
         # core
         self
         pkgs
+        myPkgs
         system
         sysLib
         nixpkgs_as_input