about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-01-13 11:27:01 +0100
committerSoispha <soispha@vhack.eu>2024-01-13 11:27:01 +0100
commit95c9314232bdebbff89f81ca3ab721e230290cec (patch)
tree7068a64c856ad5f655b4b12501c43b8a4711edcc /flake.nix
parentchore(version): v1.25.0 (diff)
downloadnixos-config-95c9314232bdebbff89f81ca3ab721e230290cec.tar.gz
nixos-config-95c9314232bdebbff89f81ca3ab721e230290cec.zip
build(treewide): Update flake and shell library
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 0b3a7bf1..27013630 100644
--- a/flake.nix
+++ b/flake.nix
@@ -19,6 +19,9 @@
         flake-utils.follows = "flake-utils";
       };
     };
+    flake-parts = {
+      url = "github:hercules-ci/flake-parts";
+    };
     haumea = {
       url = "github:nix-community/haumea";
       inputs = {
@@ -89,8 +92,9 @@
     nixVim = {
       url = "github:nix-community/nixvim";
       inputs = {
+        home-manager.follows = "home-manager";
+        flake-parts.follows = "flake-parts";
         nixpkgs.follows = "nixpkgs";
-        flake-utils.follows = "flake-utils";
         pre-commit-hooks.follows = "pre-commit-hooks";
       };
     };
@@ -138,6 +142,7 @@
         nixpkgs.follows = "nixpkgs-stable";
         flake-compat.follows = "flake-compat";
         flake-utils.follows = "flake-utils";
+        flake-parts.follows = "flake-parts";
         crane.follows = "crane";
         rust-overlay.follows = "rust-overlay";
         pre-commit-hooks-nix.follows = "pre-commit-hooks";