about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-05-20 07:40:49 +0200
committerSoispha <soispha@vhack.eu>2023-05-20 07:40:49 +0200
commit725047d31611a8ce60f86707d1d8cbd3db1a0b35 (patch)
tree647beb67e668261d376e914eb80eb8c079317ce1 /flake.nix
parentFix(hm/pkgs/scr/con2pdf): Don't try batch mode when using the Flatbed (diff)
downloadnixos-config-725047d31611a8ce60f86707d1d8cbd3db1a0b35.tar.gz
nixos-config-725047d31611a8ce60f86707d1d8cbd3db1a0b35.zip
Build(fupdate): Add generate_extensions to the inputs to avoid gc
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index b837347c..99ff50d1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -108,6 +108,15 @@
         flake-utils.follows = "flake-utils";
       };
     };
+    generate_firefox_extensions = {
+      url = "git+https://codeberg.org/soispha/generate_firefox_extension.git";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        crane.follows = "crane";
+        flake-utils.follows = "flake-utils";
+        rust-overlay.follows = "rust-overlay";
+      };
+    };
     shell_library = {
       url = "git+https://codeberg.org/soispha/shell_library.git";
       inputs = {
@@ -181,6 +190,7 @@
     # my binaries
     video_pause,
     strip_js_comments,
+    generate_firefox_extensions,
     shell_library,
     river_init_lesser,
     yambar_memory,
@@ -220,6 +230,7 @@
         
         video_pause
         strip_js_comments
+        generate_firefox_extensions
         shell_library
         river_init_lesser
         yambar_memory