about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-20 19:05:35 +0200
committerSoispha <soispha@vhack.eu>2023-08-20 19:05:35 +0200
commit69099861601d5649df737d82021a0cf5abb51403 (patch)
treee699b45ce420a56ca5f0bd17efe8fad74e73f3b5 /flake.nix
parentFix(hm/conf/neovim/plugins/luasnip): Correct local value in snippet (diff)
downloadnixos-config-69099861601d5649df737d82021a0cf5abb51403.tar.gz
nixos-config-69099861601d5649df737d82021a0cf5abb51403.zip
Feat(hm/conf/lf): Replace rename script by rename c binary
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 6be4609d..c8e95bcc 100644
--- a/flake.nix
+++ b/flake.nix
@@ -180,6 +180,15 @@
         rust-overlay.follows = "rust-overlay";
       };
     };
+    lf_rename = {
+      url = "git+https://codeberg.org/soispha/lf-rename.git";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+        flake-compat.follows = "flake-compat";
+        systems.follows = "systems";
+      };
+    };
     video_pause = {
       url = "git+https://codeberg.org/soispha/video-pause.git";
       inputs = {
@@ -293,6 +302,7 @@
     # my binaries
     video_pause,
     strip_js_comments,
+    lf_rename,
     generate_firefox_extensions,
     shell_library,
     river_init_lesser,
@@ -341,6 +351,7 @@
         
         video_pause
         strip_js_comments
+        lf_rename
         generate_firefox_extensions
         shell_library
         river_init_lesser