about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-20 08:48:00 +0100
committerene <ene@sils.li>2023-02-20 10:36:51 +0100
commit4aa5f378d2e3f6cb570ec85daa17115097a8d371 (patch)
treea79fddc156ed2a8e8b4dc0684fe9773566f1760e /flake.nix
parentFeat(flake): Reorder hosts (diff)
downloadnixos-config-4aa5f378d2e3f6cb570ec85daa17115097a8d371.tar.gz
nixos-config-4aa5f378d2e3f6cb570ec85daa17115097a8d371.zip
Feat(bootstrap): Add a script for quick activation
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix52
1 files changed, 18 insertions, 34 deletions
diff --git a/flake.nix b/flake.nix
index d8c94ad7..55302f95 100644
--- a/flake.nix
+++ b/flake.nix
@@ -68,43 +68,27 @@
           ./hosts/tiamat/configuration.nix
           agenix.nixosModules.default
 
-          home-manager.nixosModules.home-manager
-          {
-            home-manager = {
-              useGlobalPkgs = true;
-              useUserPackages = true;
-              users.soispha = import ./home-manager;
-              extraSpecialArgs = {
-                inherit
-                  sysLib
-                  strip_js_comments
-                  user_js
-                  system
-                  neovim_config
-                  impermanence
-                  snap-sync
-                  ;
-              };
-            };
-          }
-        ];
+    packages."${system}" = {
+      install = import ./bootstrap/install {
+        inherit pkgs;
+        inherit (inputs) shell-library;
+      };
+      activate = import ./bootstrap/activate {
+        inherit pkgs;
+        inherit (inputs) shell-library;
       };
-
-    nixosConfigurations.mammun = self.outputs.nixosConfigurations.tiamat;
-    nixosConfigurations.spawn = nixpkgs.lib.nixosSystem {
-      system = "x86_64-linux";
-      specialArgs = inputs;
-      modules = [./hosts/spawn/configuration.nix];
-    };
-
-    packages."x86_64-linux".default = import ./bootstrap {
-      inherit pkgs shell-library;
     };
 
-    apps."x86_64-linux"."install" = {
-      type = "app";
-      program = "${self.packages."x86_64-linux".default}/bin/install";
+    apps."${system}" = {
+      install = {
+        type = "app";
+        program = "${self.packages."${system}".install}/bin/install";
+      };
+      activate = {
+        type = "app";
+        program = "${self.packages."${system}".activate}/bin/activate";
+      };
+      default = self.apps."${system}".activate;
     };
-    apps."x86_64-linux".default = self.apps."x86_64-linux".install;
   };
 }