about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-02 14:57:01 +0200
committerSoispha <soispha@vhack.eu>2023-08-19 17:34:09 +0200
commit1194d84bda54c65b06b54d4fc5a6585aa0f7e9ec (patch)
tree32444d3526c52482d7e5b2bb0e4b0012fc470cb2 /flake.nix
parentFix(hm/packages): Add iamb and remove nheko (diff)
downloadnixos-config-1194d84bda54c65b06b54d4fc5a6585aa0f7e9ec.tar.gz
nixos-config-1194d84bda54c65b06b54d4fc5a6585aa0f7e9ec.zip
Feat(flake): Import the nixNeovim module
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index b81d2507..1cecae80 100644
--- a/flake.nix
+++ b/flake.nix
@@ -10,6 +10,21 @@
     systems = {
       url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
     };
+    poetry2nix = {
+      url = "github:nix-community/poetry2nix";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+      };
+    };
+    nixNeovimPlugins = {
+      url = "github:nixNeovim/nixNeovimPlugins";
+      inputs = {
+        flake-utils.follows = "flake-utils";
+        nixpkgs.follows = "nixpkgs";
+        poetry2nix.follows = "poetry2nix";
+      };
+    };
     flake-compat = {
       url = "github:edolstra/flake-compat";
       flake = false;
@@ -50,6 +65,15 @@
         nixpkgs.follows = "nixpkgs";
       };
     };
+    nixNeovim = {
+      url = "github:NixNeovim/NixNeovim";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+        home-manager.follows = "home-manager";
+        nixneovimplugins.follows = "nixNeovimPlugins";
+      };
+    };
     agenix = {
       url = "github:ryantm/agenix";
       inputs = {
@@ -225,6 +249,7 @@
     serverphone,
     disko,
     lanzaboote,
+    nixNeovim,
     # external dependencies
     neovim_config,
     user_js,
@@ -247,6 +272,7 @@
     pkgs = import nixpkgs (import ./system/nixpkgs {
       inherit (nixpkgs) lib;
       inherit system;
+      overlays = [nixNeovim.overlays.default];
     });
     # FIXME this `nixpkgs` misses the configs applied to the other one
     nixpkgs_as_input = nixpkgs;
@@ -261,6 +287,7 @@
         # modules
         
         home-manager
+        nixNeovim
         nixos-generators
         impermanence
         agenix