about summary refs log tree commit diff stats
path: root/bootstrap/install/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-04-29 17:31:00 +0200
committerSoispha <soispha@vhack.eu>2023-05-09 19:32:58 +0200
commitfb206f9be18b4936ef716935c2343531acaf92c2 (patch)
tree88a86e5ae9f27a050d22397cc2d991a8b9e9b70b /bootstrap/install/default.nix
parentDocs(todo): Update (diff)
downloadnixos-config-fb206f9be18b4936ef716935c2343531acaf92c2.tar.gz
nixos-config-fb206f9be18b4936ef716935c2343531acaf92c2.zip
Refactor(treewide): Use separate shell library
Diffstat (limited to 'bootstrap/install/default.nix')
-rw-r--r--bootstrap/install/default.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/bootstrap/install/default.nix b/bootstrap/install/default.nix
index 71548e90..054c28ec 100644
--- a/bootstrap/install/default.nix
+++ b/bootstrap/install/default.nix
@@ -1,12 +1,11 @@
 # vim: ts=2
 {
   pkgs,
-  shell-library,
+  sysLib,
   ...
 }: let
   dependencies = builtins.attrValues {inherit (pkgs) jq dash curl gawk btrfs-progs coreutils libuuid gptfdisk dosfstools toybox nix git;};
   name = "install";
   script = ./install.sh;
-  lib = import ../../lib {inherit pkgs shell-library;};
 in
-  lib.makeShellScriptWithLibrary {inherit dependencies name script;}
+  sysLib.makeShellScriptWithLibrary {inherit dependencies name script;}