about summary refs log tree commit diff stats
path: root/bootstrap/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-07-02 14:11:43 +0200
committerSoispha <soispha@vhack.eu>2023-07-10 16:44:21 +0200
commitee30bac65ade49ac25646f9da461a04efee8419c (patch)
tree7cf677bdb61a5bad0aae442cb0178e65481bd536 /bootstrap/default.nix
parentFix(bootstrap): Only set environment variables once (diff)
downloadnixos-config-ee30bac65ade49ac25646f9da461a04efee8419c.tar.gz
nixos-config-ee30bac65ade49ac25646f9da461a04efee8419c.zip
Fix(bootstrap): Don't wrap eev, as dash does not support exec
Diffstat (limited to 'bootstrap/default.nix')
-rw-r--r--bootstrap/default.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/bootstrap/default.nix b/bootstrap/default.nix
index f21fabe3..76968cd2 100644
--- a/bootstrap/default.nix
+++ b/bootstrap/default.nix
@@ -5,19 +5,19 @@
 }: let
   replacementStrings = {SCRIPT_ENSURE_CONFIG_VARIABLES = "${ensure_config_variables}/bin/ensure_config_variables";};
   activate = sysLib.writeShellScriptWithLibrary {
-    dependencies = builtins.attrValues {inherit (pkgs) jq gawk curl coreutils libuuid nix git;};
+    dependencies = builtins.attrValues {inherit (pkgs) jq gawk curl coreutils libuuid nix git dash gnugrep;};
     name = "activate";
     src = ./01_activate;
     inherit replacementStrings;
   };
   install = sysLib.writeShellScriptWithLibrary {
-    dependencies = builtins.attrValues {inherit (pkgs) jq dash curl gawk btrfs-progs coreutils libuuid gptfdisk dosfstools toybox nix git;};
+    dependencies = builtins.attrValues {inherit (pkgs) jq dash curl gawk btrfs-progs coreutils libuuid gptfdisk dosfstools toybox nix git gnugrep;};
     name = "install";
     src = ./01_install;
     inherit replacementStrings;
   };
   setup = sysLib.writeShellScriptWithLibrary {
-    dependencies = builtins.attrValues {inherit (pkgs) dash gawk curl git nix gnugrep nixos-install-tools coreutils libuuid;};
+    dependencies = builtins.attrValues {inherit (pkgs) dash gawk curl git nix gnugrep nixos-install-tools coreutils libuuid jq;};
     name = "setup";
     src = ./02_setup;
     inherit replacementStrings;
@@ -28,8 +28,7 @@
     src = ./03_config_setup;
     inherit replacementStrings;
   };
-  ensure_config_variables = sysLib.writeShellScriptWithLibrary {
-    dependencies = builtins.attrValues {inherit (pkgs) jq dash gnugrep curl;};
+  ensure_config_variables = sysLib.writeShellScriptWithLibraryUnwrapped {
     name = "ensure_config_variables";
     src = ./99_ensure_config_variables;
   };