about summary refs log tree commit diff stats
path: root/bootstrap/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-07-02 11:05:05 +0200
committerSoispha <soispha@vhack.eu>2023-07-10 16:44:17 +0200
commit9a76c7c7db5a1bf1952ff91dd757666903bf5236 (patch)
treeb52e00fe75d8f7fc99509097795b307b0bfcc4f3 /bootstrap/default.nix
parentFix(system/disks): Make ESP bootable (diff)
downloadnixos-config-9a76c7c7db5a1bf1952ff91dd757666903bf5236.tar.gz
nixos-config-9a76c7c7db5a1bf1952ff91dd757666903bf5236.zip
Fix(bootstrap): Finished scripts
Diffstat (limited to 'bootstrap/default.nix')
-rw-r--r--bootstrap/default.nix21
1 files changed, 11 insertions, 10 deletions
diff --git a/bootstrap/default.nix b/bootstrap/default.nix
index 60c72e6a..f21fabe3 100644
--- a/bootstrap/default.nix
+++ b/bootstrap/default.nix
@@ -3,34 +3,35 @@
   sysLib,
   ...
 }: let
+  replacementStrings = {SCRIPT_ENSURE_CONFIG_VARIABLES = "${ensure_config_variables}/bin/ensure_config_variables";};
   activate = sysLib.writeShellScriptWithLibrary {
     dependencies = builtins.attrValues {inherit (pkgs) jq gawk curl coreutils libuuid nix git;};
     name = "activate";
-    src = ./01_activate.sh;
-    replacementStrings = {SCRIPT_ENSURE_CONFIG_VARIABLES = "${ensure_config_variables}";};
+    src = ./01_activate;
+    inherit replacementStrings;
   };
   install = sysLib.writeShellScriptWithLibrary {
     dependencies = builtins.attrValues {inherit (pkgs) jq dash curl gawk btrfs-progs coreutils libuuid gptfdisk dosfstools toybox nix git;};
     name = "install";
-    src = ./01_install.sh;
-    replacementStrings = {SCRIPT_ENSURE_CONFIG_VARIABLES = "${ensure_config_variables}";};
+    src = ./01_install;
+    inherit replacementStrings;
   };
   setup = sysLib.writeShellScriptWithLibrary {
     dependencies = builtins.attrValues {inherit (pkgs) dash gawk curl git nix gnugrep nixos-install-tools coreutils libuuid;};
     name = "setup";
-    src = ./02_setup.sh;
-    replacementStrings = {SCRIPT_ENSURE_CONFIG_VARIABLES = "${ensure_config_variables}";};
+    src = ./02_setup;
+    inherit replacementStrings;
   };
   config_setup = sysLib.writeShellScriptWithLibrary {
     dependencies = builtins.attrValues {inherit (pkgs) git neovim;};
     name = "config_setup";
-    src = ./03_config_setup.sh;
-    replacementStrings = {SCRIPT_ENSURE_CONFIG_VARIABLES = "${ensure_config_variables}";};
+    src = ./03_config_setup;
+    inherit replacementStrings;
   };
   ensure_config_variables = sysLib.writeShellScriptWithLibrary {
-    dependencies = builtins.attrValues {inherit (pkgs) jq dash;};
+    dependencies = builtins.attrValues {inherit (pkgs) jq dash gnugrep curl;};
     name = "ensure_config_variables";
-    src = ./99_ensure_config_variables.sh;
+    src = ./99_ensure_config_variables;
   };
   output = {inherit activate install setup config_setup ensure_config_variables;};
 in