about summary refs log tree commit diff stats
path: root/bootstrap/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-23 17:24:37 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-24 14:40:32 +0200
commit757ebd62d153dc404f82c597984d7271ec2adba0 (patch)
tree04dc0391a9c5d49cfdf167471dcff4a5dadf6347 /bootstrap/default.nix
parentfix(modules/zsh): Support completion again (diff)
downloadnixos-config-757ebd62d153dc404f82c597984d7271ec2adba0.tar.gz
nixos-config-757ebd62d153dc404f82c597984d7271ec2adba0.zip
feat(modules/nix): Switch to `lix`
`nix` is currently constantly failing to open some of the sqlite
databases, which is just really obnoxious.

Although, as I have later found out, this is caused by a `bindfs` fuse
mount on `~/.cache`. This process is running against the `1024` open fd
soft limit, and thus refusing to open another one for the database.
Diffstat (limited to 'bootstrap/default.nix')
-rw-r--r--bootstrap/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/bootstrap/default.nix b/bootstrap/default.nix
index 1f727cd8..c47df9da 100644
--- a/bootstrap/default.nix
+++ b/bootstrap/default.nix
@@ -6,19 +6,19 @@
   ensure_config_variables_dependencies = builtins.attrValues {inherit (pkgs) systemd jq dash gnugrep curl;};
   replacementStrings = {SCRIPT_ENSURE_CONFIG_VARIABLES = "${ensure_config_variables}/bin/ensure_config_variables";};
   activate = sysLib.writeShellScript {
-    dependencies = with pkgs; [jq gawk curl coreutils libuuid nixVersions.latest git] ++ ensure_config_variables_dependencies;
+    dependencies = with pkgs; [jq gawk curl coreutils libuuid lix git] ++ ensure_config_variables_dependencies;
     name = "activate";
     src = ./01_activate.sh;
     inherit replacementStrings;
   };
   install = sysLib.writeShellScript {
-    dependencies = with pkgs; [jq dash curl gawk btrfs-progs coreutils libuuid gptfdisk dosfstools toybox nixVersions.latest git] ++ ensure_config_variables_dependencies;
+    dependencies = with pkgs; [jq dash curl gawk btrfs-progs coreutils libuuid gptfdisk dosfstools toybox lix git] ++ ensure_config_variables_dependencies;
     name = "install";
     src = ./01_install.sh;
     inherit replacementStrings;
   };
   setup = sysLib.writeShellScript {
-    dependencies = with pkgs; [dash gawk curl git nixVersions.latest gnugrep nixos-install-tools coreutils libuuid] ++ ensure_config_variables_dependencies;
+    dependencies = with pkgs; [dash gawk curl git lix gnugrep nixos-install-tools coreutils libuuid] ++ ensure_config_variables_dependencies;
     name = "setup";
     src = ./02_setup.sh;
     inherit replacementStrings;