about summary refs log tree commit diff stats
path: root/templates/latex/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'templates/latex/flake.nix')
-rw-r--r--templates/latex/flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/templates/latex/flake.nix b/templates/latex/flake.nix
index 0247cce..a87c795 100644
--- a/templates/latex/flake.nix
+++ b/templates/latex/flake.nix
@@ -72,7 +72,7 @@
       pkgs = nixpkgs.legacyPackages.${system};
 
       # This version is set automatically on `cog bump --auto`;
-      version = "v1.0.0"; # GUIDING VERSION STRING
+      version = "v%INIT_APPLICATION_VERSION"; # GUIDING VERSION STRING
 
       # TODO reduce to the needed ones
       texlive = pkgs.texlive.combined.scheme-full;
@@ -80,7 +80,7 @@
       treefmtEval = import ./treefmt.nix {inherit treefmt-nix pkgs;};
 
       build = pkgs.stdenv.mkDerivation {
-        pname = "TODO";
+        pname = "%INIT_APPLICATION_NAME";
         inherit version;
         src = ./.;
 
@@ -98,7 +98,7 @@
         '';
 
         installPhase = ''
-          install -D ./build/main.pdf $out/TODO;
+          install -D ./build/main.pdf "$out/%INIT_APPLICATION_NAME";
         '';
       };
     in {