about summary refs log tree commit diff stats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml61
1 files changed, 24 insertions, 37 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cd39eb2..1fa9668 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,46 +8,34 @@
 # You should have received a copy of the License along with this program.
 # If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
 
-[package]
-name = "yt"
-version = "1.2.1"
+[workspace]
+resolver = "2"
+members = [
+    "crates/bytes",
+    "crates/yt_dlp",
+    "yt",
+]
+
+[workspace.package]
 edition = "2021"
+version = "1.2.1"
+rust-version = "1.80.0"
+authors = ["Benedikt Peetz <benedikt.peetz@b-peetz.de>"]
+repository = "https://git.vhack.eu/soispha/clients/yt"
+license = "GPL-3.0-or-later"
+description = "A fully featured command line YouTube client"
 
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[workspace.dependencies]
+# Own Crates
+yt_dlp = { path = "./crates/yt_dlp" }
+bytes = { path = "./crates/bytes" }
+libmpv2 = { path = "./crates/libmpv2" }
 
-[dependencies]
-anyhow = "1.0.87"
-blake3 = "1.5.4"
-chrono = { version = "0.4.38", features = ["now"] }
-chrono-humanize = "0.2.3"
-clap = { version = "4.5.17", features = ["derive"] }
-futures = "0.3.30"
+# Shared
 log = "0.4.22"
-regex = "1.10.6"
 serde = { version = "1.0.210", features = ["derive"] }
 serde_json = "1.0.128"
-sqlx = { version = "0.8.2", features = ["runtime-tokio", "sqlite"] }
-stderrlog = "0.6.0"
-tempfile = "3.12.0"
-tokio = { version = "1.40.0", features = [
-  "rt-multi-thread",
-  "macros",
-  "process",
-  "time",
-  "io-std",
-] }
 url = { version = "2.5.2", features = ["serde"] }
-xdg = "2.5.2"
-yt_dlp = { path = "./crates/yt_dlp/" }
-libmpv2 = { path = "./crates/libmpv2" }
-bytes = { path = "./crates/bytes", features = ["serde"] }
-trinitry = { version = "0.2.2" }
-toml = "0.8.19"
-nucleo-matcher = "0.3.1"
-owo-colors = "4.1.0"
-
-[[bin]]
-name = "yt"
 
 [profile.profiling]
 inherits = "release"
@@ -59,7 +47,7 @@ codegen-units = 1
 panic = "abort"
 split-debuginfo = "off"
 
-[lints.rust]
+[workspace.lints.rust]
 # rustc lint groups https://doc.rust-lang.org/rustc/lints/groups.html
 warnings = "warn"
 future_incompatible = { level = "warn", priority = -1 }
@@ -90,7 +78,7 @@ unused_lifetimes = "warn"
 unused_qualifications = "warn"
 variant_size_differences = "warn"
 
-[lints.rustdoc]
+[workspace.lints.rustdoc]
 # rustdoc lints https://doc.rust-lang.org/rustdoc/lints.html
 broken_intra_doc_links = "warn"
 private_intra_doc_links = "warn"
@@ -100,7 +88,7 @@ invalid_codeblock_attributes = "warn"
 invalid_rust_codeblocks = "warn"
 bare_urls = "warn"
 
-[lints.clippy]
+[workspace.lints.clippy]
 # clippy allowed by default
 dbg_macro = "warn"
 
@@ -112,4 +100,3 @@ style = { level = "warn", priority = -1 }
 complexity = { level = "warn", priority = -1 }
 perf = { level = "warn", priority = -1 }
 pedantic = { level = "warn", priority = -1 }
-