summary refs log tree commit diff stats
path: root/sys/services/openssh/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/services/openssh/default.nix')
-rw-r--r--sys/services/openssh/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/sys/services/openssh/default.nix b/sys/services/openssh/default.nix
new file mode 100644
index 0000000..7a96441
--- /dev/null
+++ b/sys/services/openssh/default.nix
@@ -0,0 +1,17 @@
+{...}: {
+  services.openssh = {
+    enable = true;
+    allowSFTP = false;
+    openFirewall = false;
+    settings = {
+      PermitRootLogin = "no";
+    };
+    hostKeys = [
+      {
+        path = "/srv/var/lib/sshd/ssh_host_ed25519_key";
+        rounds = 1000;
+        type = "ed25519";
+      }
+    ];
+  };
+}