summary refs log tree commit diff stats
path: root/modules/nixos/plymouth.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/plymouth.nix')
-rw-r--r--modules/nixos/plymouth.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/modules/nixos/plymouth.nix b/modules/nixos/plymouth.nix
new file mode 100644
index 0000000..8e39220
--- /dev/null
+++ b/modules/nixos/plymouth.nix
@@ -0,0 +1,12 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.sils.plymouth;
+in {
+  options.sils.plymouth.enable = lib.mkEnableOption "Enable Plymouth";
+  config = lib.mkIf cfg.enable {
+    boot.plymouth.enable = true;
+  };
+}