summary refs log tree commit diff stats
path: root/hosts/thinklappi/basesystem.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/thinklappi/basesystem.nix')
-rw-r--r--hosts/thinklappi/basesystem.nix85
1 files changed, 85 insertions, 0 deletions
diff --git a/hosts/thinklappi/basesystem.nix b/hosts/thinklappi/basesystem.nix
new file mode 100644
index 0000000..e5bc5ba
--- /dev/null
+++ b/hosts/thinklappi/basesystem.nix
@@ -0,0 +1,85 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix")
+  ];
+
+  boot = {
+    initrd = {
+      availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
+      kernelModules = [];
+      luks.devices."cryptroot".device = "/dev/disk/by-uuid/6700d662-29a9-4ea5-8ca6-85d42550b3ab";
+    };
+    kernelModules = ["kvm-intel"];
+    extraModulePackages = [];
+    kernelPackages = pkgs.linuxPackages_latest;
+    loader = {
+      systemd-boot = {
+        enable = true;
+        configurationLimit = 3;
+      };
+      efi.canTouchEfiVariables = true;
+    };
+  };
+
+  fileSystems = {
+    "/" = {
+      device = "tmpfs";
+      fsType = "tmpfs";
+      options = ["defaults" "size=2G" "mode=755"];
+    };
+    "/nix" = {
+      device = "/dev/disk/by-label/nixos-root";
+      fsType = "btrfs";
+      options = ["subvol=nix" "compress-force=zstd"];
+    };
+    "/etc/NetworkManager" = {
+      device = "/dev/disk/by-label/nixos-root";
+      fsType = "btrfs";
+      options = ["subvol=networkmanagerconfig" "compress-force=zstd"];
+    };
+    "/etc/nixos" = {
+      device = "/dev/disk/by-label/nixos-root";
+      fsType = "btrfs";
+      options = ["subvol=nixconfig" "compress-force=zstd"];
+    };
+    "/srv" = {
+      device = "/dev/disk/by-label/nixos-root";
+      fsType = "btrfs";
+      options = ["subvol=srv" "compress-force=zstd"];
+    };
+    "/home" = {
+      device = "/dev/disk/by-label/nixos-root";
+      fsType = "btrfs";
+      options = ["subvol=home" "compress-force=zstd"];
+    };
+    "/srv/snapshots" = {
+      device = "/dev/disk/by-label/nixos-root";
+      fsType = "btrfs";
+      options = ["subvol=snapshots" "compress-force=zstd"];
+    };
+    "/boot" = {
+      device = "/dev/disk/by-uuid/4064-2D6C";
+      fsType = "vfat";
+    };
+  };
+
+  swapDevices = [];
+
+  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+  # (the default) this is the recommended approach. When using systemd-networkd it's
+  # still possible to use this option, but it's recommended to use it in conjunction
+  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+  networking.useDHCP = lib.mkDefault true;
+  # networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
+  # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+  hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}