summary refs log tree commit diff stats
path: root/hosts/hpserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/hpserver.nix')
-rw-r--r--hosts/hpserver.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/hosts/hpserver.nix b/hosts/hpserver.nix
new file mode 100644
index 0000000..47d3e25
--- /dev/null
+++ b/hosts/hpserver.nix
@@ -0,0 +1,19 @@
+{...}: {
+  role.sils = "workstation";
+  sils = {
+    disks.disk = "/dev/disk/by-id/wwn-0x600508b1001c0d733397035f990e3942";
+    meta = {
+      globalDataDir = "/srv";
+      hostname = "hpserver";
+      system = "x86_64-linux";
+    };
+  };
+  nixpkgs.config.permittedInsecurePackages = [
+    "olm-3.2.16"
+    "python3.12-youtube-dl-2021.12.17"
+  ];
+  nixpkgs.overlays = [(self: super: {utillinux = super.util-linux;})];
+
+  home-manager.backupFileExtension = "backup";
+  boot.initrd.availableKernelModules = ["ehci_pci" "ata_piix" "uhci_hcd" "hpsa" "usb_storage" "usbhid" "sd_mod"];
+}