summary refs log tree commit diff stats
path: root/hm/mako/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/mako/default.nix')
-rw-r--r--hm/mako/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/hm/mako/default.nix b/hm/mako/default.nix
new file mode 100644
index 0000000..503ca1b
--- /dev/null
+++ b/hm/mako/default.nix
@@ -0,0 +1,40 @@
+{...}: {
+  services.mako = {
+    enable = true;
+    #backgroundColor = "#2e3440";
+    #borderColor = "#88c0d0";
+    borderRadius = 25;
+    borderSize = 2;
+    defaultTimeout = 5000;
+    #font = "Source Code Pro 10";
+    width = 500;
+    height = 500;
+    icons = true;
+    ignoreTimeout = true;
+    layer = "overlay";
+    markup = true; # TODO
+    maxIconSize = 64;
+    sort = "-time";
+    #extraConfig = ''
+    #  [urgency=low]
+    #  border-color=#cccccc
+
+    #  [urgency=normal]
+    #  border-color=#d08770
+
+    #  [urgency=high]
+    #  border-size=3
+    #  border-color=#bf616a
+    #  default-timeout=0
+
+    #  [urgency=critical]
+    #  border-size=4
+    #  border-color=#bf616a
+    #  default-timeout=0
+
+    #  [category=mpd]
+    #  default-timeout=2000
+    #  group-by=category
+    #'';
+  };
+}