summary refs log tree commit diff stats
path: root/flake/nixosConfigurations/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake/nixosConfigurations/default.nix')
-rw-r--r--flake/nixosConfigurations/default.nix23
1 files changed, 5 insertions, 18 deletions
diff --git a/flake/nixosConfigurations/default.nix b/flake/nixosConfigurations/default.nix
index f7ffbc6..56dd741 100644
--- a/flake/nixosConfigurations/default.nix
+++ b/flake/nixosConfigurations/default.nix
@@ -27,24 +27,17 @@
       };
     }
   ];
-  nixosConfig = {
-    hostname,
-    mainDisk,
-    rootPart,
-    bootPart,
-    system ? "x86_64-linux",
-  } @ conf:
+  nixosConfig = system: file:
     nixpkgs.lib.nixosSystem {
       inherit system;
-      specialArgs = attrs // conf;
+      specialArgs = attrs;
       modules =
         [
           (import ../../modules/nixos)
           (import ../../sys)
           (import ../../secrets)
-          (import ./basesystem.nix)
-          (import ../../hosts/${hostname}.nix)
-          {home-manager.extraSpecialArgs = attrs // conf;}
+          (import file)
+          {home-manager.extraSpecialArgs = attrs;}
         ]
         ++ defaultModules;
     };
@@ -58,13 +51,7 @@ in {
   #    ]
   #    ++ defaultModules;
   #};
-  thinklappi = nixosConfig {
-    hostname = "thinklappi";
-    rootPart = "/dev/disk/by-uuid/6700d662-29a9-4ea5-8ca6-85d42550b3ab";
-    mainDisk = "/dev/disk/by-uuid/68da1329-f5ea-4f2c-a38e-faffaaaa6b5a";
-    bootPart = "/dev/disk/by-uuid/4064-2D6C";
-    system = "x86_64-linux";
-  };
+  thinklappi = nixosConfig "x86_64-linux" ../../hosts/thinklappi.nix;
   thinklappi-bootstrap = nixpkgs.lib.nixosSystem {
     system = "x86_64-linux";
     specialArgs = attrs;