summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 5 insertions, 8 deletions
diff --git a/flake.nix b/flake.nix
index 788c09a..95f46e5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -73,18 +73,15 @@
       };
     };
     lanzaboote = {
-      url = "github:nix-community/lanzaboote/v0.3.0";
+      url = "github:nix-community/lanzaboote/v0.4.1";
       inputs = {
-        crane.url = "github:ipetkov/crane/27025ab71bdca30e7ed0a16c88fd74c5970fc7f5";
-        nixpkgs.url = "github:NixOs/nixpkgs/2057814051972fa1453ddfb0d98badbea9b83c06";
+        crane.follows = "crane";
+        nixpkgs.follows = "nixpkgs";
         flake-compat.follows = "flake-compat";
-        flake-parts = {
-          follows = "flake-parts";
-          inputs.nixpkgs-lib.follows = "nixpkgs-lib";
-        };
+        flake-parts.follows = "flake-parts";
         flake-utils.follows = "flake-utils";
         pre-commit-hooks-nix.follows = "git-hooks";
-        rust-overlay.url = "github:oxalica/rust-overlay/1d8fcbbfcfd3476c2665384a46ee9d07ef2b4dd9";
+        rust-overlay.follows = "rust-overlay";
       };
     };