summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-02-07 20:45:04 +0100
committersils <sils@sils.li>2023-02-07 20:45:04 +0100
commite28d7dbbd537371bac22aa2576bfbe9809c04bbf (patch)
tree0125bf1628e9635d1668a3b5437b3ccbcbe58943 /flake.nix
parentUpdate: flake.lock (diff)
downloadnix-config-e28d7dbbd537371bac22aa2576bfbe9809c04bbf.tar.gz
nix-config-e28d7dbbd537371bac22aa2576bfbe9809c04bbf.zip
Update: Added home-manager and specify nixpkgs.url
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 37a7906..a41d092 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,10 +1,17 @@
 {
+  description = "My Nixo system configuration";
+  inputs = {
+    nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+    home-manager.url = "github:nix-community/home-manager/master";
+  };
   outputs = {
     self,
     nixpkgs,
-  }: {
+    ...
+  } @ attrs : {
     nixosConfigurations.thinklappi = nixpkgs.lib.nixosSystem {
       system = "x86_64-linux";
+      specialArgs = attrs;
       modules = [./sysconf/thinklappi.nix];
     };
   };