summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-06-30 19:35:28 +0200
committersils <sils@sils.li>2023-06-30 19:35:28 +0200
commitc13a3b624e2653d4d72c278236fd717567dbb59f (patch)
treeea0c0b0290c1209d33ec4a90d4a80c13fa25010f /flake.nix
parentFeat(sys): Add fwupd (diff)
downloadnix-config-c13a3b624e2653d4d72c278236fd717567dbb59f.tar.gz
nix-config-c13a3b624e2653d4d72c278236fd717567dbb59f.zip
Feat(hosts/thinklappi): Enable secureboot with lanzaboote
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 4685562..97560f3 100644
--- a/flake.nix
+++ b/flake.nix
@@ -10,6 +10,10 @@
     };
 
     # inputs for following
+    lanzaboote = {
+      url = "github:nix-community/lanzaboote/v0.3.0";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
     systems = {
       url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
     };
@@ -97,18 +101,19 @@
     yambar_memory,
     #grades,
     prismlauncher,
+    lanzaboote,
     ...
   } @ attrs: let
     system = "x86_64-linux";
     pkgs = nixpkgs.legacyPackages."${system}";
-    
+
     sysLib = shell_library.lib.${system};
   in {
     nixosConfigurations.thinklappi = nixpkgs.lib.nixosSystem {
       inherit system;
       specialArgs = attrs;
-#nixpkgs.overlays = [ polymc.overlay ];
       modules = [
+        lanzaboote.nixosModules.lanzaboote
         ./hosts/thinklappi
         home-manager.nixosModules.home-manager
         {
@@ -117,7 +122,7 @@
             useUserPackages = true;
             users.sils = import ./users/sils;
             extraSpecialArgs = {inherit pkgs system sysLib river_init_lesser yambar_cpu yambar_memory prismlauncher;};
-        };
+          };
         }
       ];
     };