summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-10-12 13:48:00 +0200
committersils <sils@sils.li>2023-10-12 13:48:00 +0200
commitb170ccfbca5460f011d0b5262ab6044bf2e83df2 (patch)
tree2ae4982d0d90e0aa012b68812bfe7f4ac6d21269 /flake.nix
parentbuild(flake): update (diff)
downloadnix-config-b170ccfbca5460f011d0b5262ab6044bf2e83df2.tar.gz
nix-config-b170ccfbca5460f011d0b5262ab6044bf2e83df2.zip
feat(u/sils/packages): add wl-togglescreens
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 42ade2d..39387a2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -98,6 +98,10 @@
     prismlauncher = {
       url = "github:PrismLauncher/PrismLauncher";
     };
+    wl-togglescreens = {
+      url = "git+https://git.project-insanity.org/onny/wl-togglescreens.git?ref=main";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
   };
   #}}}
   outputs = {
@@ -113,6 +117,7 @@
     lanzaboote,
     nixvim,
     impermanence,
+    wl-togglescreens,
     ...
   } @ attrs: let
     system = "x86_64-linux";
@@ -130,7 +135,7 @@
           useGlobalPkgs = true;
           useUserPackages = true;
           users.sils = import ./users/sils;
-          extraSpecialArgs = {inherit pkgs system sysLib river_init_lesser yambar_cpu yambar_memory prismlauncher nixvim impermanence;};
+          extraSpecialArgs = {inherit pkgs system sysLib river_init_lesser yambar_cpu yambar_memory prismlauncher nixvim impermanence wl-togglescreens;};
         };
       }
     ];