summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSilas Schöffel <sils@sils.li>2024-04-04 16:49:18 +0200
committerSilas Schöffel <sils@sils.li>2024-04-04 16:49:18 +0200
commit6ae04281d89a896041aac413fa9fb5d628152228 (patch)
tree90602c213c1e04ce512cc2e9171eb8b2907c72d3 /flake.nix
parentfoot: remove manual theming (diff)
downloadnix-config-6ae04281d89a896041aac413fa9fb5d628152228.tar.gz
nix-config-6ae04281d89a896041aac413fa9fb5d628152228.zip
nixvim: move theming config into flake.nix
This allows me to stay with a themed standalone neovim package output
while having my installed neovim themed with stylix.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index e4c34b1..d5c31db 100644
--- a/flake.nix
+++ b/flake.nix
@@ -173,7 +173,12 @@
         inherit system;
         overlays = [nixvim.overlays.default];
       };
-      nixVimConfig = import ./users/sils/nixvim/config.nix pkgs;
+      nixVimConfig =
+        (import ./users/sils/nixvim/config.nix pkgs)
+        // {
+          colorschemes.gruvbox.enable = true;
+          plugins.airline.settings.theme = "minimalist";
+        };
       nvim = nixvim.legacyPackages."${system}".makeNixvim nixVimConfig;
     in {
       devShells.default = pkgs.mkShell {