summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-05-05 17:49:06 +0200
committersils <sils@sils.li>2023-05-05 17:52:30 +0200
commit29a25be45ba7c7dd425719f32eee8bd7e3cef2b0 (patch)
treea379c1e6726f6d625ad72a4c0b3b80ca677ad6df /flake.nix
parentFeat(users/sils): Add direnv (diff)
downloadnix-config-29a25be45ba7c7dd425719f32eee8bd7e3cef2b0.tar.gz
nix-config-29a25be45ba7c7dd425719f32eee8bd7e3cef2b0.zip
Feat(flake.nix): Add devShell output
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 7e892be..96fc132 100644
--- a/flake.nix
+++ b/flake.nix
@@ -13,7 +13,8 @@
     home-manager,
     ...
   } @ attrs: let
-    system = "86_64-linux";
+    system = "x86_64-linux";
+    pkgs = nixpkgs.legacyPackages."${system}";
   in {
     nixosConfigurations.thinklappi = nixpkgs.lib.nixosSystem {
       inherit system;
@@ -29,5 +30,14 @@
         }
       ];
     };
+    devShells."${system}" = {
+      default = pkgs.mkShell {
+        packages = with pkgs; [
+          nil
+          statix
+          alejandra
+        ];
+      };
+    };
   };
 }