summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSilas Schöffel <sils@sils.li>2024-04-05 01:15:43 +0200
committerSilas Schöffel <sils@sils.li>2024-04-05 01:15:43 +0200
commit0fdbf0ff9053ff754a94b26f3401e29c14ad1bcb (patch)
tree9cb1cc020e24bcfbd975c6f9f8b89089ac2b8f40 /flake.nix
parentswaylock: remove background image (diff)
downloadnix-config-0fdbf0ff9053ff754a94b26f3401e29c14ad1bcb.tar.gz
nix-config-0fdbf0ff9053ff754a94b26f3401e29c14ad1bcb.zip
theming: change theme to tokyo-night-dark
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index a30b7fb..f4ca43e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -87,6 +87,8 @@
         rust-overlay.follows = "rust-overlay";
       };
     };
+
+    # Theming
     stylix = {
       url = "github:danth/stylix";
       inputs = {
@@ -95,6 +97,11 @@
         flake-compat.follows = "flake-compat";
       };
     };
+
+    base16-tokyo-night-scheme = {
+      url = "git+https://git.michaelball.name/gid/base16-tokyo-night-scheme.git";
+      flake = false;
+    };
     systems = {
       url = "git+https://codeberg.org/sils/systems"; #  specify systems to evaluate
     };
@@ -154,6 +161,7 @@
   #}}}
   outputs = {
     self,
+    base16-tokyo-night-scheme,
     nixpkgs,
     home-manager,
     prismlauncher,
@@ -208,6 +216,7 @@
       nixosConfigurations = import ./flake/nixosConfigurations {
         inherit
           self
+          base16-tokyo-night-scheme
           nixpkgs
           home-manager
           prismlauncher