summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-01-19 22:17:23 +0100
committersils <sils@sils.li>2023-01-19 22:17:23 +0100
commit01cc32c5d9dd7bf548eda1fe626e59e79eda72ad (patch)
tree83ae0da53ea07867e6d25b08c47a35de79db0cc2 /flake.nix
parentFormat: Format Code (diff)
downloadnix-config-01cc32c5d9dd7bf548eda1fe626e59e79eda72ad.tar.gz
nix-config-01cc32c5d9dd7bf548eda1fe626e59e79eda72ad.zip
Structure: Flakeify
Flakes enable a lot of nice options.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..16f49fb
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,11 @@
+{
+  outputs = {
+    self,
+    nixpkgs,
+  }: {
+    nixosConfigurations.thinklappi = nixpkgs.lib.nixosSystem {
+      system = "x86_64-linux";
+      modules = [./configuration.nix];
+    };
+  };
+}