{...}: {
  services.openssh = {
    enable = true;
    settings.PasswordAuthentication = false;
    hostKeys = [
      {
        path = "/srv/sshd/ssh_host_ed25519_key";
        rounds = 1000;
        type = "ed25519";
      }
    ];
  };
}