summary refs log tree commit diff stats
path: root/tests/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/default.nix')
-rw-r--r--tests/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/default.nix b/tests/default.nix
new file mode 100644
index 0000000..d9b354a
--- /dev/null
+++ b/tests/default.nix
@@ -0,0 +1,13 @@
+{
+  specialArgs,
+  nixLib,
+  pkgs,
+}: let
+  tests = nixLib.mkByName {
+    baseDirectory = ./by-name;
+    fileName = "test.nix";
+    finalizeFunction = name: value:
+      import value (nixLib.warnMerge specialArgs {inherit pkgs;} "the test args set");
+  };
+in
+  tests